Ce document décrit l’installation, la configuration et l’exécution d’Apache 2.4 avec mod_ssl pour les système d’exploitation Linux Debian 9, Ubuntu 14.04 et Ubuntu 16.04.

Installation du paquet Apache2 et activation du module SSL

Vérifiez si Apache est installé et avec quelle version

apache2 -v

Si il n’est pas installé ou que votre version est inférieure à 2.4.13, installez le paquet

Debian 9Ubuntu 16Ubuntu 14

sudo apt install apache2

sudo apt install apache2

sudo add-apt-repository ppa:ondrej/apache2
sudo apt-get update
sudo apt install apache2

Activez les modules ssl

sudo a2enmod ssl
sudo a2ensite default-ssl.conf

Installation OpenSSL

Vérifiez si OpenSSL est installé et avec quelle version

openssl version

Si il n’est pas installé ou que votre version est inférieure à 1.0.2g, installez le paquet

Debian 9Ubuntu 16Ubuntu 14

sudo apt install openssl

sudo apt install openssl

sudo add-apt-repository ppa:0k53d-karl-f830m/openssl
sudo apt-get update
sudo apt-get install openssl

Configuration SSL

Les applications Web développées par Veremes utilisent le protocole SSL pour communiquer. Afin de pouvoir utiliser les applications, veuillez suivre la procédure suivante :

Configuration SSL